0

In our content type (document set), we have a 'Name' column ('file' column type), that has the name of an applicant to a position.

Upon first designing the library, we thought we would have unique document sets for every applicant, in which we put every possible application. In other words: one file per person, with every application he/she makes inside. We enforced unique values to ensure we didn't have duplicate files.

However, afterwards we decided to have multiple files per application and add metadata to stipulate which position he/she wants etc.

I cannot seem to change the unique values that were enforced for that column before. On the column edit page, the 'enforce unique values' option is not visible.

This is causing colleagues to have to use "Firstname Lastname-", "Firstname Lastname--" etc. as names, which is rather silly.

Anyone know how to fix?

See image, it's in Dutch but shows the page without the possibility to edit the 'unique values' feature.

Column edit page

  • a picture might help to illustrate the problem? – Tally May 17 '18 at 8:44
  • I uploaded it, however it's in Dutch so I hope it's clear... – Tomverff May 18 '18 at 8:57
  • "I cannot seem to change the unique values that were enforced for that column before. On the column edit page, the 'enforce unique values' option is not visible." -> do you have Content Types enabled? It could be that a column in the Content Type is still set to 'Required' whereas in the List settings for that column could be set to 'Optional'. – Tally May 18 '18 at 10:03
  • Content types are enabled, there are about 20 content types using the column atm. But initially it was enforced as a column that had to have unique values. Also, it can stay 'required', the values just can't be unique anymore. – Tomverff May 18 '18 at 18:36
  • The column in question is the FileLeafRef column for the document set. Could it be that this column HAS to be unique? Or can I change it to allow duplicate values? – Tomverff May 18 '18 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.