0

I am farm Admin of SharePoint 2010 environment. i am trying to delete some user profile from central admin but it is giving me "access denied" error.

This is what i am doing. 1. open central admin 2. go to application management then manage service application 3. select user profile service application. (note that i have given explicit permission to myself for this service by clicking 'administrators' and 'permissions' icon on the top of the page) 4. select Manage user profiles 4. search for specific profile and the delete. here i am getting access denied error.

can anyone tell me why i am getting access denied error.

  • As the simple solution doesn't work, please help us by providing ULS-Logs. – MHeld May 15 '18 at 14:26
0

Log in to the SharePoint Server and open CentralAdmin via Start Menu entry SharePoint 2010 Central Administration. This will run InternetExplorer as Administrator.

0

Open Central admin in the Browser with Administrator mode -> Go to Service Applications in Central admin -> Select User Profile Service Application -> Check the "administrators" in the ribbon. If the user is not an admin, please add it in administrators. if he is already in the group, you can go and delete the user profile.

  • 1
    please read my question again.. i have clearly mentioned that i have already tried this and it is not working – Rahil Jan Muhammad May 15 '18 at 6:41
0

Running your browser in administrator mode does nothing other than run the browser process itself in administrator mode, i.e. that process is running on your machine as an administrator. It does nothing for SharePoint as central administration is a web site and not your browser. This advice is akin to saying run your browser in administrator mode then you have administrator access to www.microsoft.com!

The ULS logs are going to contain useful information on the access denied error. My guess is it's related to the profile database and permission on it or you don't have permissions on the UPS service application.

  • I have seen several scenarios where functions in CA were hidden or caused AccessDenied errors when just starting IE and typing CA URL in it. epmgelist.wordpress.com/2013/06/14/… – MHeld May 16 '18 at 12:03
  • And those are due to the access level of the user running Internet Explorer on the SERVER and/or SHAREPOINT i.e. they don't have local administrative rights on the server and/or they don't have farm admin rights. It has nothing to do with what mode Internet Explorer is run in. If anything Internet Explorer is one of the last processes you want to run as administrator. – DubStep Jun 13 '18 at 14:33
  • Please explain the behavior in this video: youtube.com/watch?v=wQs8Y69KIho – MHeld Jun 13 '18 at 16:02
  • You just showed me a video without the permission levels of the user on the machine or in SharePoint. So in short, I can't with incomplete information. And that appears to be on a VM or possibly in a standalone farm or development environment. All things I do not run and fall into the not a true real world environment that end users would use. I have never EVER run IE as administrator on a in service SharePoint system, production or pre-production. It's a permission issue, probably linked to the built-in administrators group being relied upon for SharePoint permissions if I had to guess. – DubStep Jun 20 '18 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.