0

I am creating a simple workflow for my contacts list in a SharePoint site where users enter the full name of a user from the Active Directory and a workflow will auto populate other columns such as "Job title" and "Email Address".

Set Email Address to Current Item:Full Name

then Set Job Title to CUrrent Item:Full Name

When i publish this workflow on designer, the progress bar completes in an instant which points to having something wrong. This workflow does not show up in "Workflow Settings" on my contacts lists.

I tried creating the same workflow for another test contacts list on another site collection and the progress bar takes ~10 seconds to create, validate and publish the workflow. This workflow works on this contacts list.

I have tried :

  • Comparing both site collections, changing site features to match the other site collection and making sure i have full control permissions for both sites.

  • Clearing designer cache before publishing workflow

  • Making sure both contacts lists have the same settings and
    permissions

Edit 1: I noticed the problem being when i hit publish workflow, no .xsn form is created in SharePoint Designer for the site i am working on but for other site collections when i publish a workflow it always takes ~5 seconds to publish and it creates an .xsn form form created when publishing workflow

  • Can you try creating a new contacts list and creating the same workflow for the new list which you created. – Anupam Jagatdeo May 15 '18 at 3:02
  • I have tried that, no workflows can be published/created for site collection. I tried creating a new site collection with same site permission groups and it works over there. – Kev F May 15 '18 at 3:14
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – Asad Refai May 15 '18 at 5:27
  • Hey Kev F... The initaition form will not get generated if you haven't selected the workflow trigger option to manually start the workflow. Please check the option to manually trigger the workflow and you would see the Initiation form once you publish again. – Anupam Jagatdeo May 15 '18 at 6:12
  • I have ticked automatically start workflow when item created/changed and also ticked manually start workflow options and published but the workflow still does not show up in workflow settings – Kev F May 15 '18 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.