2

For reasons unknown, I'm currently having an issue where a single sitecollection in my SP2016, doesn't receive updates from the Content Type Hub - Neither content types nor fields. Every other site does.

I have run the timer jobs multiple times. I have tried setting the 'Refresh all published content types' flag in the site settings. I have tried creating new content types and deployed them without success. The Content type service application error log shows no errors.

The site has publishing features enabled - I don't know if it matters, but it is the only obvious difference between that and the other sites.

The site contains a lot of content, so deleting it and creating a new one is not possible.

Any idea what might be wrong with the site?

Is it possible to take the field via powershell (or otherwise) from the Content Type Hub, and deploy it to the site and the content type on the site? Preferably in a way so that it is 'linked' to the content type hub the way it would be normally.

1

Does this site collection with a blank site at top-level site template?

If yes, you need to enable Taxonomy Feature via:

Enable-SPFeature -id 73EF14B1-13A9-416b-A9B5-ECECA2B0604C -URL

Also, make sure the fun hidden SharePoint Metadata features were active on the site.

  • What do you mean by "Also, make sure the fun hidden SharePoint Metadata features were active on the site."? – Johan Brännmar May 8 '18 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.