0

I see below error when I try to open a SharePoint online site. Any idea why it happens?

SharePoint Designer Error

  • is it multi-factor enabled ? – Gautam Sheth May 4 '18 at 4:12
2

None of the remedies I read online worked for me. They used to work but not any more. What ultimately worked seems counter-intuitive and backward but, here it is:

I had to use Internet Explorer (not Edge or Chrome) and open a classic site's library/list (or open any library list in classic mode) and navigate to SPD through its ribbon, the old fashioned way. It worked as expected (if I tried the same thing in Edge, it denied me access giving me the list of 4 reasons it wasn't working which, of course, were irrelevant). Once I successfully opened SPD2013 for the one site in the manner, then I could type in the URL and open any site in my tenant, classic or modern, via the SPD app without issue.

1

Notwithstanding the previous answers, I have experienced this issue before. The answer to your problem is to enable legacy authentication on your SharePoint Online tenant:

Set-SPOTenant -LegacyAuthProtocolsEnabled $true

After successfully running that command SPD should authenticate properly. If not, you need to have your Azure admin un-block legacy authentication for you or an Azure AD group to which you belong. This can be done under the Conditional Access section of Azure AD. reference

0

Please try the following steps to check the outcome:

  1. Remove SharePoint Designer 2013 related credentials. To do it, open Control Panel > Credential Manager > Windows Credential > Generic Credentials, then delete any items which contains MicrosoftOffice15_Data.
  2. Try signing in with your Office 365 account again.

Reference: https://answers.microsoft.com/en-us/msoffice/forum/msoffice_o365admin-mso_dep365/we-are-unable-to-sign-you-into-office-please/c9be3ddc-2859-4f8c-b5c8-1d49a8ab17fb

0

I recommend to check your permission in the web site, ensure you have enough permission to open the web site in SharePoint Designer. Go to Site Permissions > Permission Level in ribbon > Click the permission you belongs to > Ensure Use Remote Interfaces is selected.

You can also test add yourself into the "Site collection administrators" and then have a test.(site settings > Site collection administrators)

If above methods do not work, you can try to use https instead of http as url to connect to your Sharepoint site in designer.

Check if below article is useful to you:

https://social.technet.microsoft.com/Forums/en-US/15fd1436-3166-4e43-8b22-cdb480091548/cant-open-sharepoint-online-site-in-sharepoint-designer-2013?forum=sharepointcustomization

Not the answer you're looking for? Browse other questions tagged or ask your own question.