0

As there are so many articles published over the internet likely similar issue but none of them is useful in my case.

I have a public facing site and my I want to share only single page resides inside "site pages" library. for that, I have enabled Anonymous access to all the zones from CA and set Anonymous User's "Permission Levels" to Lists and libraries (inside SP site) and inside site pages library, restrict Anonymous users to View Items only.

Now I believe everything is ready to access the site from outside.

But when I access the site it asked for credentials though I don't have anything pending for approval.

I am also NOT using publishing portal so Limited-access user permission lockdown mode feature is not there and also I am using SharePoint 2010.

Once the user passes the credentials, the whole site is accessible. (I am using Alternate access mapping AAM) to access it publicly.

How to fix the mentioned issue, please suggest.

  • Make sure a major version of all items is there... read only allows access to the major versions of files. Are you getting a SP Access denied or a prompt? – Heiko Hatzfeld_MSFT May 2 '18 at 18:37
  • SP prompting for credentials, and I don't have any publishing libraries. apart from that, I am accessing the page which contains HTML only, which will push data into SP list. users getting prompt while navigate to that page or site. – Rishi Jagati May 2 '18 at 19:02
  • 1
    what I meant is do you get the access denied page from sharepoint or do you get the page displayed when you cancel the prompt. It could be mysite images on the page (different webapp/site) or some other resources (Fiddler is your friend then or F12) – Heiko Hatzfeld_MSFT May 2 '18 at 19:06
  • It is prompting for creds for the whole site when user click on cancel browser shows This page isn’t working If the problem continues, contact the site owner. HTTP ERROR 401 – Rishi Jagati May 2 '18 at 19:11
  • I would check the uls log then... You said its a simple html page.. – Heiko Hatzfeld_MSFT May 2 '18 at 19:25
0

You have to give entire site for them to see pages. Otherwise they can only interact with list items and libraries (like submit form data, view form data, view list items populated in a web part etc.) My suggestion would be to move that page to it's own library or subsite, set unique permissions on that location then set anonymous permissions there.

  • set access to list and libraries and the page inside the library which considered an item. and I already tried with the entire site option but no luck. – Rishi Jagati May 2 '18 at 18:59
  • It doesn't work that way. You can't put a page in a list, so it can't be a list item. Pages have to go in libraries. If they are meant to view pages, you need to use the entire site option. If they are still getting login prompts, it's likely due to something the page is referencing that they don't have anonymous access to or something not published. – DubStep May 3 '18 at 17:45
  • Page inside the sitespages library. And I am using teamsite template also all files are published. Entire site option is enabled for anonymous permission. – Rishi Jagati May 4 '18 at 7:13
  • Something is causing the 401 (authentication) request. Fiddler or the browser console should give some clues as to what. But leaving it in the root site site pages library without breaking inheritance, if you set anonymous entire site from that level, you are going to make EVERYTHING anonymous, unless that is the desired outcome. – DubStep May 7 '18 at 19:10
0

Finally, I have fixed the issue.

All the settings I have made for Anonymous access in SharePoint is correct, but the issue is with public IP mapping with the SharePoint site port.

Public IP mapping has been done in DNS which pointing to port 80 and my site port is different. after changing my extended (HTTP) web application port to 80 from IIS, it is now accessible to end users WITHOUT credentials.

I know it's a very silly mistake I have made!! but thank you, everyone, for your suggestions.

  • Instead of changing it from IIS, you should remove and re-add or change the mapping (via PowerShell) within SharePoint so it's in the config database or the next time the foundation web service is restarted on a web front end, your IIS changes will be reverted to what is in the config database. – DubStep May 8 '18 at 13:39
  • Good point to implement. Thx – Rishi Jagati May 8 '18 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.