1

I have created a SharePoint list with 60+ columns and only few columns require user input. I created a view with only those column however when they click on Edit the form shows the entire columns instead of the current view. I am using SharePoint 2010. Can someone please help me with a resolution.

For e.g. I have created column 1 to 50 but I want users to update only column 1, 3 , 5 ,11 and 15.

  • If customization with designer is ok then you create a new list add form through designer and remove the columns that are not required – Sunil Sahu Apr 27 '18 at 11:46
1

You can hide it to appear on forms,

  • go to List Settings -> Advanced Settings -> Allow management of content types -> check the box

  • Now come back to List Settings -> Under Content Types -> Click Item content type -> Under columns -> click The column -> Hidden (check the box)

  • Now it won't appear on the forms, you can similarly remove it from Views.

You need to only do this if you don't want above columns to not be search means when columns are hidden they does not get crawled. Refer here

  • Thank you Sunil. I tried this however I still see other columns in the Form even after I changed them to Hidden. – Chris Sahu Apr 27 '18 at 12:29
  • What is the content type of the columns , please share your new item form url and is custom form or SharePoint default form – Sunil Sahu Apr 27 '18 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.