0

We had an orphaned site in a content database, and the health analyzer indicated as such. This orphan site was cleaned up via Powershell. However, this did not clean up the health analyzer warning. It now shows an OrphanApp error for the orphan site that no longer exists.

Title - Missing server side dependencies. 

Explanation:
[OrphanApp] App [0ca0a76a-0b45-4f40-b5ca-a9446fc9275f] is orphaned in the database [SP_Content_Collab] on site collection [c53bceda-f5c7-4d32-a72f-f57e8a810e2e]. Orphaned Apps are not accessible, cause unnecessary resource and license consumption and may fail upgrade. Try to uninstall this App. App [0ca0a76a-0b45-4f40-b5ca-a9446fc9275f] is orphaned in the database [SP_Content_Collab] on site collection [c53bceda-f5c7-4d32-a72f-f57e8a810e2e]. Try to uninstall this App. If the App uninstallation is failing, it needs to be unblocked before the orphan App can be removed. 

How do I clean this up in a supported fashion? I tried the uninstall app comandlet which did not work.

There is this question, which strikes me as unsupported.

SP 2013, service pack 1 mark 2, so 15.0.4571.1502

1

I had a similar scenario and was able to resolve it. I've adjusted the parameters to match your Site Collection ID, but you'll want to fix the database name.

$db = Get-SPContentDatabase -Identity SP_Content_Collab
$db.ForceDeleteSite('c53bceda-f5c7-4d32-a72f-f57e8a810e2e', $false, $false, $false, $true)

Re-run the health analyzer rule after running this.

  • The management shell isn't recognize the ForceDeleteSite with 5 arguments, does it need cast into Microsoft.SharePoint.Administration somehow instead of the powershell method? – Eric Alexander Apr 19 '18 at 17:55
  • No, this is an OOTB method. What version/patch level are you running of SharePoint? You might also try casting the GUID to [guid]$g = 'c53bceda-f5c7-4d32-a72f-f57e8a810e2e'. – Trevor Seward Apr 19 '18 at 18:25
  • 2013, service pack 1 mark 2, so 15.0.4571.1502 – Eric Alexander Apr 19 '18 at 18:29
  • Yep, the new overloads are on 2016... Given that, I'd recommend opening a support case with Microsoft. They can 'bless' direct database edits. – Trevor Seward Apr 19 '18 at 21:55
  • 1
    We got blessed to run a provided SQL query to resolve it. Ultimately this would have fixed it if we were current. – Eric Alexander Jun 28 '18 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.