0

I have created a script to fetch data from the list in SharePoint Online. To do so, there has been given a REST call to the list to fetch data. There is one user who is facing the issue that is shown in the screenshot.

enter image description here

https://<<siteCollection>>/_api/web/lists/getbytitle('FAQ')/items?$select=*,Function/Title,Region/Title&$expand=Function,Region

The issue comes for the one user only. Other users who has permission on the site are able to see the records as expected.

Any ideas?

6
  • Please double check the permission of this specific user. Apr 18, 2018 at 7:56
  • User has been given Contribute permission on the list.
    – users1100
    Apr 18, 2018 at 8:00
  • Well in this case there should not be any problem..It should work. Can you share your code ... Apr 18, 2018 at 8:05
  • what the endpoint you are calling ? also, are your custom js files checked in ? Apr 18, 2018 at 8:11
  • Modified question. @GautamSheth
    – users1100
    Apr 18, 2018 at 8:35

1 Answer 1

0

As mentioned in comments, based on the REST query that you have posted, you are using lookup columns.

So, you need to provide access to the lookup lists (could be named Function and Region) as well besides the FAQ list.

For that particular user or a SharePoint group, you can provide the minimum read permissions so that you can fetch data from those lists as well.

Summary - Just provide the basic read permissions on the 3 lists namely FAQ, Function and Region and you are good to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.