1

I recently migrated a site from 2007 to 2016 (both on-prem) using Sharegate. There was a web part on one of the pages that was not going to be compatible with 2016. That page is now broken in 2016 because of that web part

Sorry, something went wrong. Could not load file or assembly 'webpart name, Version=1.0.0.0, Culture=neutral, PublicKeyToken=abcdef' or one of its dependencies. The system cannot find the file specified

I want to just edit the page and delete the broken web part but adding the edit URL to the page or adding ?content=1 is not working, I still have the error message. I also tried uploading the old web part files to the 2016 Web Part Gallery (didn't really think that would work).

How do I remove the web part reference in the 2016 version?

  • 1
    Note sure if this will work with 2016, but you could try to add ?contents=1 at the end of the link. Source: sharepoint.stackexchange.com/questions/7225/… – Marc-André Apr 17 '18 at 17:48
  • @douvillema Thanks for the suggestion already tried that with no luck – user3587336 Apr 17 '18 at 17:54
  • My bad, I didn't saw that you tried the ?content=1. Nevermind! – Marc-André Apr 17 '18 at 18:07
3

The ?contents=1 is working properly in SharePoint 2016

https://siteURL/pagename.aspx?contents=1

But in your case, I think you need to remove the WSP solution that contains this web part from the farm as the following:

Retract & Remove the WSP solution

Uninstall-SPSolution -Identity contoso_solution.wsp

After retracting the wsp solution, remove it.

Remove-SPSolution -Identity contoso_solution.wsp

For more details check UNINSTALL A SHAREPOINT (WSP) SOLUTION PACKAGE

After that, you should go back to your page that should be opened properly, then remove the broken web part.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.