0

So I have a InfoPath form embedded into my site, working with all aspects correctly, even when you submit it pushes that as a row into a datalist in another page. My concern is that 4 existing fields in my datalist exist and receive data into InfoPath from my current data connection, but will not populate a multi-select list box. I have other multi-select fields working. Here are some images to try to show my struggle (Its as if InfoPath just doesn't know how to populate it from the data passed by SharePoint, but in SharePoint all of the data fields are kosher..)

When I first insert the multiselect boxes, I go to the fields pane on the right, right click and add multi-select box (which automatically binds to that field) enter image description here

A double check to see that the fields values were found, and that they should populate just like the previous times that worked (see image following) enter image description here

When I go to test run the environment, I see the other multiselect list boxes show up, but these don't. enter image description here

Even if I try to publish, I get the error saying there was an object mismatch. enter image description here

My next step is to delete each field not working and reinsert it, then try again. But I just can't think of what else this might be. The form works as expected other than this.

0

A fix was to delete those cells entirely and recreate the table. Then it worked as expected. Solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.