0

We are using SP2010 on-premise and InfoPath 2010. Recently we found one of InfoPath library's workflow page got error. After investigate the ULS log, the error is "System.ArgumentException: Column 'ABCIniti' does not exist. It may have been deleted by another user."

The library have a designer workflow (2010) named "ABC Initial workflow". The workflow have been published since several years ago and more then 20 versions have been published before. The lookup column "ABC Initial workflow" is existing since day 1 we published the workflow. Right now, it just disappear without any warning. In the "Create View" page, we can no longer see the look up column. Recently we have not touched anything related to this workflow or this library.

By googling the error, I found one of the work around is to delete all the association with this workflow and then publish it again. It will force SharePoint re-create this lookup column.

However, it is not a good solution to us because we have 500+ running instance of this workflow "ABC Initial workflow". It will impacting too many users if we re-run the 500+ workflows.

Could you please advice any workaround and any reason the column disappear itself?

P.S. I have changed "List View Lookup Threshold" from 8 to 16 and perform IISreset already.

  • Just a heads-up. Increasing the lookup threshold might cause bad performance and deadlocks for the database. – Christoffer Apr 9 '18 at 5:23
  • @Christoffer thanks for reminding, I wish it could be resolved in other way... SharePoint is really a living monster – Mark L Apr 9 '18 at 5:40
  • SharePoint is fine. SQL Limits.. not so fun. :) Have you tried to just republish the workflow and see if the columns get added back? – Christoffer Apr 9 '18 at 5:53
  • @Christoffer Yes tried to republish and no different. – Mark L Apr 9 '18 at 6:01
  • Does it get added as another instance? – Christoffer Apr 9 '18 at 6:52
1

I had the same exact problem (and using Nintex Workflows) and could not afford to delete the existing workflows (80% still in progress). After many struggles and grey hair, I got a solution of some sort:

  • Go to the library -> library settings -> workflows
  • Identify the current workflow (I could see many previous versions in my attempt to get the workflow column name created) and ensure it has 0 workflows in progress. If not, republish the existing workflow.
  • Click on the Remove a workflow and delete the workflow (radio button). This will cause the workflow to go unpublished.
  • Open the Nintex workflow gallery and you will notice the workflow is now unpublished.
  • Publish the workflow.
  • Run the workflow at least once to ensure it has been compiled. And viola! The workflow name is appearing as a column in your library! This also solved the issue of the error page showing up when you open the workflow status/history of the item. The previous version workflow is till running.

The downfall of this solution is that the workflow status of the previous version is not shown in the new column - only the new workflows for the current version.

  • Although I have already deleted all workflows (all new and old version) and republish the workflow, I think your solution worth a try next time. Thank you. – Mark L Oct 9 '18 at 1:44
0

Are new processes being added to the workflow? How many items are being changed and updated in your workflow? You could have runout of processing space in the workflow. I beleive, and someone can correct me if I am wrong, you get 75 XML nodes within you workflow build in the back-end before it is maxed. It could be a new process in your workflow has pushed you beyond this limit. Try removing a process from the workflow and see if it starts working again. You can always put it back.

  • We have not changed the workflow in question as well as other workflow since Jan but the error only occur since last week. All those workflows are being called every day so items (forms and list items) will be add/update/remove day-to-day by workflows. – Mark L Apr 10 '18 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.