I currently have my SharePoint 2010 server set up with twelve content databases. In each is or should be one site collection at the moment, but as I went through to set up each one five of them gave me the following error:


The URL 'Reporting Templates/audit.xlsx' is invalid. It may refer to a nonexistent file or folder, or refer to a valid file or folder that is not in the current Web.

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: 20185930-c5b1-4abc-84b5-e5709e1d2241

Date and Time: 11/22/2011 11:02:40 AM

I've checked in C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\FEATURES\Reporting\Templates and confirmed that Audit.xlsx does exist.

Here's my method that I've been using to set up these site collections in these CDBs:

  1. Stop all content databases.
  2. Start only the content database I want to create a site collection in.
  3. Using Central Administration go to Application Management -> Create Site Collections.
  4. Enter the appropriate information. (I'm using the managed path [with Wildcard inclusion] http://servername/departments/ for all of these initial site collections. The only things that change are the title and the URL of each site collection.)
  5. Hit OK.

There seems to be no rhyme or reason as to why those five specific CDBs wouldn't accept a site collection. While the other seven worked just fine.

Why can't I create site collections in those five CDBs?

Edit: I've tried creating a directory in ...\FEATURES called "Reporting Templates" and copying the contents of ...\Reporting\Templates into it in an effort to match the directory that the error says it's trying to reach. When I go to create a site collection I get the exact same error, though.

Edit 2: Using the SharePoint 2010 Management Shell and the following command I get the exact same error.

New-SPSite http://***/departments/clientservices -OwnerAlias ***\*** -ContentDatabase WSS_Content_Client-Services -SecondaryOwnerAlias ***\*** -Template STS#0 -Name "Client Services"

Edit 3 - 1/5/2012: If I remove RBS from one of the misfit CDBs and try to add a site collection using the command from Edit 2 it installs correctly! We've narrowed it down to an RBS issue, ladies and gentlemen! Additionally after creating that site collection and then reinstalling RBS trying to create another site collection returns the original error.

RBS breaks things. Great.

  • If you take a look at the SQL permissions between a database where this works, and a database where it does not work, is there a difference in which accounts have access and what their rights are?
    – shufler
    Commented Nov 23, 2011 at 19:54
  • @shufler - Nope, they're identical to the ones that work.
    – newuser
    Commented Nov 23, 2011 at 20:46
  • Is this an out of the box site definition you're creating the site collection with or is it custom? Is this the same as the sites that work? You could try searching the 14\TEMPLATES (sub)folders for audit.xlsx to see which template it is using if not sure or to confirm.
    – shufler
    Commented Nov 23, 2011 at 21:02
  • @shufler - OOB. All are using the same template.
    – newuser
    Commented Nov 28, 2011 at 14:25
  • 1
    Release To Manufacturing. It's the first version released to the public. In SharePoint 2010's case, you have the version released in April 2010. Since then there has been a cumulative update released every two months. SP1 was released in June and there have since been two more CUs. See here for updating SharePoint: technet.microsoft.com/en-us/sharepoint/ff800847
    – shufler
    Commented Dec 6, 2011 at 18:24

5 Answers 5


You might be able to get a bit more information about the events that lead up to the error by checking the log files in

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS

ULS Viewer is a utility that can be used to view, sort, filter etc the log entries based on, for example the correlation id that you are given by the erorr page.


  • +1 for good troubleshooting step
    – shufler
    Commented Dec 6, 2011 at 1:17
  • I've taken a look at the appropriate log entries and unless I'm missing something they aren't telling me anything that the error page told me. What am I looking for?
    – newuser
    Commented Dec 6, 2011 at 14:05
  • @JonnyP - Sorry, they aren't telling me anything that the error page hasn't told me already.
    – newuser
    Commented Dec 6, 2011 at 14:46
  • What happens if you just create new content databases for the sites that aren't working? Would you eventually end up creating all your site collections? If so then just delete all the old non-working dbs when you are done.
    – Paul Lucas
    Commented Dec 7, 2011 at 23:19
  • @PaulLucas - I was kind of trying to avoid that, because I'm not 100% sure how to remove the RBS I've installed on each of my current CDBs.
    – newuser
    Commented Dec 9, 2011 at 14:15

I may have an answer for you. If my answer is correct, please answer the couple of questions at the end just for my reference.

Check your configuration database for GUIDs with null values. We had the same error and discovered a GUID with null values. Once you have that GUID, you can execute this script to delete the reference to the GUID with null values from your configuration database.

Please be aware that this will modify your configuration database, so you should take every step to back it up and ensure that you have a valid restore point prior to executing this:

$wa = get-spwebapplication | ? {$_.displayname -eq "YOURWEBAPPLICATION"}

If this works, could you let me know:

  1. What was the GUID for your null value content DB?
  2. What patch level are you running?

We saw the exact same error, but site collection creation failing maybe 20% of the time. As it ends up, we have many content databases per web app, so it was only failing periodically because of the 1 content database that didn't exist.

Hope this helps!

Edit: I don't find any "official" sources on this. We developed this solution with Microsoft's support. If you wish, you can contact them directly to verify the solution. I'm wondering if this is a SP1 or August CU issue, however, so it may be rare, new or not previously known.

Posting the SQL command here for clarity:

select * from dbo.Objects (nolock) 
WHERE Properties LIKE '%<fld type="null" />%'
  • Can you be a lot more specific with what you're talking about? Where exactly am I looking for GUIDs? By "configuration database" I assume you mean SharePoint_Config in MS SQL Server Management Studio, but I don't know for sure.
    – newuser
    Commented Dec 5, 2011 at 20:04
  • Maybe he is talking about the SiteMap table in the config database?
    – Nat
    Commented Dec 6, 2011 at 1:15
  • If I understand correctly, it sounds like you are saying that there could be are content databases that are in a state between online and not attached to the farm. They are referenced somewhere in some database but are missing a GUID, or the GUID in the database is not present? The scenario sounds interesting, but I'm not clear where these values should (or should not?) exist.
    – shufler
    Commented Dec 6, 2011 at 1:16
  • Sorry for the delay in getting back. No e-mail notifications on replies? :( Commented Dec 8, 2011 at 14:38
  • Yes, sharepoint_config is the appropriate database, and I believe that the sitemap table does act as an index for the content databases in the farm. What you could do is run a select statement on that table, grab the GUIDS, then cross-reference those with the content databases in CA, or export a list of content databases via Powershell. The offending reference should be evident when you look at the entries in the sitemap table. Commented Dec 8, 2011 at 15:02

In cases where I am creating new site collections and I need them to be in a specific content databases I typically script it with PowerShell. The New-SPSite command will create a site collection, and gives you an option to identify the content database that it uses.

That doesn't appear to be the error though. Looking at your error, it looks to me that you are not using a standard SharePoint site definition/template. Is this something you previously exported, and if so are all of the dependencies installed? Looks like there is a feature or something referencing an excel file.

  • The template I'm using is the OOB Team Site template.
    – newuser
    Commented Nov 28, 2011 at 14:25

Did you check this post where a solution was implemented for a similar problem?

The issue was said to be resolved by recreating the existing SharePoint farm. Though I don't have a clear idea how this is accomplished, I would advice to take all kinds of backup possible, before trying this solution.


What worked for me was to simply disable RBS, then create the site collection, then re-enable RBS (after this, I could create new site collections normally):

$cdb=Get-SPContentDatabase <ContentDbName>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.