0

I have a custom list and would like to reference the information in a SPFX web part. I'm following the sharepoint-crud sample from github as an example.

When I make the call to the desired list with no select filter, my columns are returning as follows:

  • Email is appearing as OData__x0063_424
  • Job Description is appearing as OData__x0073_no1
  • Job Title is appearing as x4y6

How can I make the fields appear in the api call with their actual column names instead of gibberish?

4

That is happening because you are creating list columns directly from the page.

Like in below image.

enter image description here

Instead of doing that, would suggest that you go to the list/library settings page by clicking on the gear icon in top right corner and then click on list or library settings.

After that, click on create column option, do scroll down a bit and then do the needful.

enter image description here

And then this

enter image description here

More documentation - Create column in SharePoint

In the above link, check how we can create column in SPO as well as SP 2013/2016. This is the way we used to create columns in the old days.

  • I figured it would be something along the lines of this, but wasn't sure what I was missing. Cheers! – vanblart Apr 6 '18 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.