0

My InfoPath form had been working fine but suddenly any new entries after submit hang on "Sending data to the server". Oddly enough the new data is written BUT the workflows that should begin now do not. The other clue is that I can still start the approval workflow manually but when I try to approve, after clicking "approve" now it would just be stuck on "Working on it - please wait while your task is updated."

And lastly when I try to manually approve it through "workflows" on the browser, I get

Sorry, something went wrong 
This task is currently locked by a running workflow and cannot be edited.

I have scoured the web for answers, I have tried everything from clearing the browser cache to swapping over a "larger" copy of Core.js and nothing.

I could sure use some good karma back my way. I have a day trying to get this to work.

  • Suspend the running workflow and try to execute it manually. WF must be erring out and hence you are getting sending data to server forever. – Deepmala Apr 5 '18 at 5:58
0

About your first issue:

Which browser did you use?

I suggest you use the IE, if you use the IE11, I suggest you use the IE11 32 bit.

This is a reference about a similar case.

About your second issue:

You can add the UpdateTask activity in your workflow to update properties.

This is similar case for your reference.

  • Hello Peter and thank you. I am not much of a coder, would you kindly point out out how I may use this? I do not see any functions in the workflow in SPD that call UpdateTask? – Mike Rooker Apr 5 '18 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.