2

When I trying to access the "Configure App URL" property in central administrator I met a strange exception "Settings or services required to complete this request are not currently available. Try this operation again later. If the problem persists, contact your administrator". After google I refer the link which I shared below.

http://www.sharepointpals.com/post/Settings-or-services-required-to-complete-this-request-are-not-currently-available-Try-this-operation-again-later-If-the-problem-persists-contact-your-administrator

Based on the above shared forum I restart the following services. 1. App Management Service Application 2. Microsoft SharePoint Foundation Subscription Settings Service Application 3. Managed Metadata

But still the issue is coming. Kindly guide to resolve this issue.

0

To restart the services, You can do it via CA.

  • Login on Central admin using Farm admin account
  • go to System Settings > Manage Services in server
  • Now look for the required services applications (MMS, AMS, SSS) and Stop them, wait for till its status says stooped then click start it. repeat it for all required service applications.
  • If you have to multiple Servers in farm, then you have to make sure you restart the services on the All servers where it is running.

Check this: http://krossfarm.com/?p=1145

  • Hi Waqas, Thanks. I restarted the service but still this issue is there and need solution for it. – Kaliaperumal S Apr 4 '18 at 5:59
0

App Management Service and Subscription Settings Service both need a Proxy to work properly. Please check if they are available by going to CentralAdmin -> Application Management -> Manage Service Applications. Also note that ServiceApplication and Proxy need the status "Started". Should look like this:

App Management Service

Subscription Settings Service

0

After restart these services , perform IISRESET on the all servers .

Also , Please verify the AMS and SSS have permission :

Select the App Management Service Application (Microsoft SharePoint Foundation Subscription Settings Service Application)

Permissions in the Ribbon add the user name

  • After restarted the services and I reset the IIS also but still in same state. – Kaliaperumal S Apr 4 '18 at 9:35
0

If the services are all running and available you need to check the service associations.

Make sure the services are all part of the default proxy group. YOu can find the settings in the CA under:

http://spfarm-sp:8080/_admin/ApplicationAssociations.aspx

Make sure to display the "Service Applications" in the dropdown on the top right side.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.