2

we have already workflow manager 1.0 installed and processed workflows successfully.

We deleted the site where the workflows are subscribed and the associated workflow scopes status become unregistered. We tried republishing the workflows but still unable to process the workflows.

So we are planning to reinstall the workflow manager.

So so we need to uninstall every component in workflow manager and reinstall them from the beginning or can we specifically uninstall few components and reinstall them ?

4
  • 1
    How many scopes are affected? If it is only a one or a few I would engage MS Support to get the script to reset those scopes back to active Apr 3, 2018 at 12:43
  • @HeikoHatzfeld_MSFT, sorry for delay . could you please help with the script to make the scopes active. We have only one scope affected.
    – kumar
    May 10, 2018 at 6:32
  • The solution I have needs approval to run, so please open a case. You could try the following: Backup-spsite , delete the site and restore it from the backup (Should generate a new site ID, which should be a new scope -I THINK- not tested since I have the other script- May 10, 2018 at 9:28
  • @HeikoHatzfeld_MSFT. i resolved this issue with removing all previous workflow scopes and recreated the new workflow scope and then republished the workflows. Thanks
    – kumar
    May 14, 2018 at 13:27

4 Answers 4

1

I do not think you have to re-install any of your WFM components.

It sounds like you have deleted the site that was used in the SPSite parameter when registering a workflow scope with Register-SPWorkflowService cmdlet.

In that case you have a couple of options to get it re-registered:

  • Delete the old scope and re-run the Register-SPWorkflowService cmdlet - Remove Workflow Manager scopes?
  • Re-run Register-SPWorkflowService cmdlet but with the -Force parameter
  • Re-run Register-SPWorkflowService cmdlet but with a new scope name

Than re-publish your workflow definitions and check that the workflow subscriptions are still there.

There is a similar issue - I think - described here: https://blogs.msdn.microsoft.com/spses/2016/08/09/sharepoint-2013-spd-2013-workflows-are-getting-associated-with-the-list-but-they-arent-starting/

2
  • thanks for the answer. It helped me to resolve the issue.
    – kumar
    May 14, 2018 at 13:28
  • Good to hear! Feel free to mark my answer as the correct one. May 14, 2018 at 16:33
0

There are couple of steps:

  • Delete the Application Proxy from Central admin
  • remove the Workflow Manager Cert from the Central admin > maange trust.(if using the SSL connection).
  • On WFM server, Runt he wizard and Leave the server from Farm (workflow Manager wizard).
  • Delete all accosicated databases.
  • Unistall the WFM, Service Bus, WFM Client from the Control panael (add remove program).
  • Delete the registry keys (HKLM\Software\Microsoft\Workflow Manager and HKLM\Software\Microsoft\Service Bus)
  • Delete the folder.(C:\Program Files\WorkflowManager and Service Bus installs at C:\Program Files\ServiceBus)

Here is the step by step guide: SharePoint 2016 Uninstall the Workflow Manager 1.0 and https://blogs.msdn.microsoft.com/biztalknotes/2014/03/10/how-to-uninstall-workflow-manager-1-0-when-the-command-remove-wfhost-does-not-work/

0

The great blog article describing how to uninstall Workflow Manager if remove-wfhost does not work, has been moved.

The new link is: How to uninstall Workflow Manager 1.0 when the command ‘Remove-WFHost’ does not work.

-1
  1. Download the setup from this link

https://www.microsoft.com/en-us/download/details.aspx?id=35375

  1. For configuring you can follow the below link

https://www.c-sharpcorner.com/article/install-workflow-manager-1-0-for-use-in-sharepoint-2013/

Thanks and let me know if it doesn't helps.

2
  • Please don't post link-only answers, include the relevant portion from the links. Links can expire. Apr 3, 2018 at 12:37
  • Noted. Going forward will do the same.
    – Sukumar MS
    Apr 3, 2018 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.