0

I have a site, which was created using sharepoint online, that works fine on Chrome and Firefox but not working in IE11. It works fine once I change the document mode (in developer mode) to 11 instead of 10. Not sure how to make it work without changing the document mode as this is not a solution (Can't change this setting for the computers of anyone who visits the website).

  • I already tried all of them and nothing work except changing the document mode. The concole shows an error SCRIPT5009: 'Set' is undefined. require-951f856e.js (1,1662) – SMH Mar 28 '18 at 23:04
  • Hard to tell without seeing the site, but it sounds like you have customizations that are breaking the site. The fix is to get the developers who built the customizations to fix them. – Derek Gusoff Mar 29 '18 at 2:16
  • You can set it up in master page adding <meta http- equiv="X-UA-Compatible" content="IE=10" />. I have done it sharepoint.stackexchange.com/questions/220838/… – user70011 Mar 29 '18 at 3:05
  • I already tried that but it makes no difference – SMH Mar 29 '18 at 3:07
  • can you add <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /> to the <head> tag in master page and check ? Once done, checkin and publish the masterpage. By doing this, it will force the compatibility mode to edge(i.e latest) wherever available. – Gautam Sheth Mar 29 '18 at 6:58
0

Did you add some custom code in the site in SharePoint online?

To troubleshoot the issue, check things below:

  1. Add the site into compatibility view in IE11.

  2. Clear IE cache.

  3. Reset IE settings. Go to IE->internet options->advanced tab->reset.

  4. Switch to other computer to check if the same issue will occur.

There is a similar post:

https://stackoverflow.com/questions/49501116/react-set-is-undefined-on-sharepoint

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.