0

my secure store service application is throwing an error calle d"an internal database error occurred in the secure store".

  1. I verified app pool and it is working fine.
  2. on Manager server section - I see claims as well as secure store service is up and running.
  3. I tried to refresh the key using phas phrase which was used for farm connection. And still same error.

This was starting after cumulative updates installed( CU version November 2017). This is for SharePoint 2013. Can anyone please help us?

  • did you ran the config wizard after the CU installation, just double checking? whats the complete error you are seeing, any thing in ULS lgos? – Waqas Sarwar MVP Mar 27 '18 at 21:18
  • yup. Just fixed the issue. I have two app servers. One App server App pool running with this service has different account than the other app pool. I changed the account to proper service account which has permissions to database. It is working fine now. – raj Mar 27 '18 at 21:35
0

My issue has been fixed by following belwo steps.

  1. very two app servers for errors and check which under which app server it is failing. I verified in event viewer.
  2. verified that secure store is running under different app pool with different service account in one APP server.
  3. I changed back/ moved it to original App Pool along with the proper account which has permissions to Secure score database.
  4. IISRESET.
  5. everything started working fine

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.