0

SharePoint 2010 : Windows Server 2008 and We have few custom solutions deployed. Recently added a new WFE and re-deployed all solutions in the Farm. but in new WFE, few assemblies are missing and facing error with custom Web part that assembly is missing.

Tried re-deploying using PowerShell with GAC deployment, CA UI. Same error.

I could see the assemblies in old WFEs in installed Library, but could not locate the DLL file of the assembly while opening assembly in Windows Explorer view.

Is there a way to locate the DLL of an installed assembly or copy the installed assembly file directly to new WFE server.

0

There should have been no need to redeploy. SharePoint would manage that itself for the farm solutions.

The only way I can imagine this broke is if there was an update for the webpart that removed dependencies from the wsp file. This could lead to a missing dll in the new server, since the new server will get the wsp and extract it locally.

Key question: Which DLL is missing? Was it listed as a requirement for the webpart in the documentation? (WSP with common, shared DLLs can cause other issues if you have the same dll in 2 WSP files for example)

  • Thanks for your reply @Heiko-Hatzfed, missing assemblies are ICSharpCode.SharpZipLib and one custom assembly. It was developed by a vendor long back, so we do not have the source code or DLL files. Also we could not locate the DLL of installed assembly in old WFE. – Anand Rajendran Mar 28 '18 at 12:18
  • you have the wsp's for that webpart? Maybe there is more than one version of them? You can extract them and check the contents to see the DLLs – Heiko Hatzfeld_MSFT Mar 28 '18 at 17:05
  • Yes, i have the latest version of wsp file. Extracted and checked, DLL is not part of it. Unfortunately we don't have the old versions of WSP file. – Anand Rajendran Apr 10 '18 at 12:34
  • got the old version of the DLL in the GAC? extract it from the old server and manually deploy it onto the new one (via gacutil)... And make a note in the DR Documentation about it and document the manual change... – Heiko Hatzfeld_MSFT Apr 10 '18 at 13:39
  • I see the assembly in the installed assembly library, but i could not find the DLL of that assembly in the GAC. I tried it via gacutil, command prompt but no luck. – Anand Rajendran Apr 11 '18 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.