1

I am running Microsoft SP Designer v15.0.4551.1001 and I cannot open a workflow in the designer for a 365 SharePoint Online site. I get the following error -

Windows workflow foundation, part of .Net Framework 3.0, must be installed to use this feature

I have tried to clear the cache files at - %APPDATA%\Microsoft\Web Server Extensions\Cache %APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache %USERPROFILE%\AppData\Local\Microsoft\WebsiteCache

Still no joy. Any tips advise how to resolve?

Any suggestions would be appreciated.

0

Does the workflow has some lookups which are referenced. this could also cause the above mentioned problems

Check out this blog here for more information about workflows with lookups.

you can also try this method.

To resolve this issue please update your designer with the hotfixes in sequence. Make sure the designer is NOT open.

http://support2.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2837667&kbln=en-us

http://support2.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2727100&kbln=en-US

Once installation is complete open the site once again. A restart may not be necessary. If you still get the same issue then clear your designer cache by running this

rmdir "%LOCALAPPDATA%\Microsoft\WebsiteCache\" /s /q rmdir "%APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache\" /s /q

Then Restart you PC. Found in this blog. Also make sure you read comments section, as people do post some solutions that might work for someone. you could also try those methods if something does not work for you.

  • Hi Manish, I have tried the above and still no joy. Does it matter if I am running Windows 10 Enterprise? – S60AUN Mar 21 '18 at 10:34
  • I dont think so that should have any impact on the above as long as you are sharepoint designer licensed version. – Manish Oswal Mar 21 '18 at 11:19
  • I will try building a VM and try if the installation works on a clean install. Nightmare. – S60AUN Mar 22 '18 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.