1

This is my current top navigation bar.

Top navigation example

The Home, Functional Areas, and Applications are all linking to the site collection home page (/sites/sitename/). Because all three are linking to the same page, while on this page the Applications link is selected as the active navigation (Through some testing, it appears that whatever the last link in the navigation for the current page will be the selected link).

Is there something I can put in the "URL" property for these links that will prevent anything from happening? When I tried putting javascript: return true; an error for not including https:// was thrown, and putting exactly https:// breaks the link and saving fails.

Edit: Adding images of my Navigation edit page. enter image description here

0

I get the same results as you get.

Resolution:

Display this navigation node as a text-only heading.

Steps:

  1. If you are using the Structural Navigation, leave the URL text box for “Functional Areas” and “Applications” blank.

    enter image description here

  2. If you are using the Managed Navigation, select “Simple Link or Header” node type under Navigation tab for the “Functional Areas” and “Applications” term and leave it blank.

    enter image description here

  • I'm not sure where you are seeing these settings? I'm updating the post with what my edit navigation page looks like – vanblart Mar 16 '18 at 14:00
  • Enable the publishing features: 1. On the Site Collection Features page, activate SharePoint Server Publishing Infrastructure. 2. On the Site Features page, activate SharePoint Server Publishing. After that, you can navigate to "Navigation" under "Look and Feel" on the site settings page. – JoannaW_MSFT Mar 19 '18 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.