I am trying to return all items with my custom content type applied but all the ContentType property is set to Item. Not sure what I am missing here. I have added my content type to my list and populated the columns. These columns have data if I search via the title but I cannot search on ContentType. Any ideas?

search results


1 Answer 1


I believe though you have added content type to a list but you haven't set it to default. And all the items have been created with default CT i.e. Item.

Modify the view and check the CT for all the items. Confirm for list settings if custom CT is selected as default CT.

  • It does not need to be the default, but it does need to be assigned. Make sure you have assigned the correct Content Type to the item and then recrawl the list. Mar 13, 2018 at 18:49
  • @MatthewMcDermott, how do you assign the Content Type? Mar 13, 2018 at 19:16
  • @MatthewMcDermott, I changed the order of the content types and set the custom type as default and the content type is still set to Item in the search results Mar 14, 2018 at 3:17
  • Did you assign the Content Type to the Items? You do this in the Metadata of the item. Mar 14, 2018 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.