0

I have a user that is trying to edit a page and use Insert > Upload File through the ribbon to add a file download link to the page. Once they select the file and click "OK" they are getting a Request Access error page in the dialog. I've tried granting Full Control permissions (as a test), but this did not resolve the error.

I've checked and both the designated document library and page are inheriting permissions from the Site Collection, as well as with another User with matching permissions (who was able to properly upload the file).

What would cause this behavior other than a permissions issue?

  • Have you checked the Style Library permissions? – Tally Mar 8 '18 at 13:50
  • I had not! What role does the Style Library play in this process? – vanblart Mar 8 '18 at 14:12
  • We sometimes put custom scripts in the Style Library, if users do not have access to the library, the page will not load, because they don't have access to the script. (Sorry, I should have explained that originally. though re-reading your question I'm not sure my comments are valid) – Tally Mar 8 '18 at 16:05
  • After updating the User's permissions in the Style Library they were able to update the page properly. Just not sure why the Style Library would interfere with their permissions for a different Page/Library – vanblart Mar 8 '18 at 16:49
  • 1
    Ah good, so that fixed it. I suppose the Style Library must contain some elements of pages, so users need 'access' to the Style Library, otherwise Sharepoint's logic is that the user should not see these elements of the page – Tally Mar 9 '18 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.