2

I just noticed that the access request page in some of the site collection is not working. I have assigned new user for permissions that is also a site collection admin, has full control to the site collections owners group, but still no luck. This may have been caused due to promoting site to site collection, i am not sure, but other sites that i have promoted access request is working fine, i have used the same method (doc ave content organizer).

None of this works, i have tried all of the steps:

  1. Recreate owners group and assign new owner or same owner
  2. give permissions to user/approver to the access request list
  3. tried to request access by using user that did not have permissions to the list. No matter what when approver clicks to the "accept or decline this request" from the email the page is empty even though the user can get to the page meaning that the user has access to the access request list. New request is showing on the rss feed while it does not show on the pendingreq.aspx page. The only thing the approver set see is below: access request

It looks to me that the pendingreq.aspx page is corrupted. I can however get to the oldreq.aspx by directly entering it in the url by removing pendingreq.

0

I also noticed the same thing a while ago on one of the tenants. When the link HIDE HISTORY/SHOW HISTORY is clicked, the list of requests/users is shown for a moment and then hidden again. It turns out that there is some script on the page that adds opacity: 0; to the style of the MSOZoneCell_WebPartWPQ5 div (div that contains all the requests).

So the temporary fix was to open developer tools in the browser (press F12), find the div and manualy change the style setting to opacity: 1;. That way you should be able to see all the requests. This isn't appropriate for non-technical users, of course, but until Microsoft fixes the problem we cannot do much more about it.

  • MSOZoneCell_WebPartWPQ5 is not even here, it only has up to WebPartWPQ3. I opened two pending.aspx page in SharePoint designer side by side with one not showing pending requests and other showing pending requests and i noticed that XsltListViewWebPart is missing on the one that is not showing pending requests. – user51776 Mar 6 '18 at 21:22
  • #Delete the access request list by navigating to all files. #Use below PowerShell to delete web properties that still exists. #Request access with user that do not have access to the site. #you have have to do this on each site you have this issue on. Add-PSSnapin Microsoft.SharePoint.PowerShell $WebURL = "contoso.com/sites/rootsite" $key1 = "_VTI_ACCESSREQUESTSLISTID" $key2 = "_VTI_PENDINGREQUESTSVIEWID" $Web = Get-SPWeb -Identity $WebURL $Web.AllowUnsafeUpdates = $true $Web.AllProperties.Remove($key1) $Web.AllProperties.Remove($key2) $Web.Update() $Web.Dispose() – user51776 Jun 13 '18 at 20:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.