1

We're trying to apply SP1 to SharePoint 2013 on a Clients farm. We've sucessfully done this on their test environment and are pretty happy with the steps to take.

However, on one of the Application Servers in the Production Farm the status of the Server is 'Upgrade Blocked' and the rest say 'Installation Required'

I've googled Upgrade Blocked but the only articles I can find are not very helpful. Hence my queston here.

Is this because this server needs patching to same level as the other servers in the farm ? Or is this server patched to a higher level than all the others and will be excluded from SP1 being applied ? Or is it something else entirely ?

Thanks in advance for all advice/information

Dan

  • You can go to upgrade and migration page in central admin to possibly find more details. – Vineet Desai Feb 21 '18 at 10:13
1

You need to install the CU on the servers saying "Installation Required".

Do it for all until you see "Upgrade Available", then run PSConfig on all servers.

Upgrade blocked just means that a server is already patched to a level higher than the rest, and is blocking further upgrades until the rest have caught up.

  • Thanks everyone. Your answers have helped massively to clarify the situation the client finds themselves in and gives me a way forward. – Dan Feb 22 '18 at 10:10
4

"Upgrade blocked" means that this server has upgrades installed which are missing on other servers with status "Installation required".

Move to CA -> Upgrade and Migration -> Check product and patch installation status. Compare exactly the installed updates on each server and find out which one is missing.

You can find more information about Versions and installed updates in this excellent article: SharePoint does not have a build version. Full Stop.

4

There are 2 things:

Installation required: When you install the patch on one server in farm but not on other servers then all other servers status will be installation required.

Upgrade blocked: Now, on the server where you installed the updates that server status become upgrade blocked un till you run the PSconfig wizard.

You have to check which patch installed on that server which they did not installed on other servers. So install that patch on remaining servers then run the config wizard.

0

I had the same issue. I did read an article that said it was best to start the installation with the app servers and then the web server.

https://collab365.community/installing-updates-on-sharepoint-2013/

To fix the issue before that I simply re-ran the update and then the config on the app server then the web. Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.