1

My current setup is that i have sharepoint sitting on the port 80 and 443 with portal.company.com, and i would like to extend the application to use the 8080 port additionally, but on the different dns name (mportal.company.com). Unfortunately, simply extending the app is not working, because the browsers (chrome, ie) are redirecting to the https site on the port 8080, which obviously does not exist. If you have any recommendations for how to host such a scenario, please leave a comment down below. Some magic sharepoint documentation is welcome too.

  • Windows Server 2012 R2
  • Sharepoint 2013 Foundation
  • IIS 8.5

Web Applications management - central administration

Portal http://servername port 80

Alternative Access Mapping

+----------------------------+----------+---------------------------+
|        internal URL        |   Zone   |        Public URL         |
+----------------------------+----------+---------------------------+
| http://servername          | Default  | http://servername         |
| http://portal.company.com  | Intranet | http://portal.company.com |
| https://portal.company.com | Intranet | http://portal.company.com |
| http://mportal.company.com | Intranet | http://portal.company.com |
+----------------------------+----------+---------------------------+

IIS

+---------------------+---------------------------------------------+
|        site         |                   binding                   |
+---------------------+---------------------------------------------+
| portal.company.com  | *:80 (http), portal.company.com:443 (https) |
| mportal.company.com | mportal.company.com:8080 (http)             |
+---------------------+---------------------------------------------+

Even without the redirection (in postman) i cannot access the site using ntml auth. I could do it with portal.company.com but not with mportal instead :<

Is it maybe possible with UrlRewrite2 module for IIS

1

looks like AAM is not correct From checking your AAM

|        internal URL        |   Zone   |        Public URL         |  
+----------------------------+----------+---------------------------+  
| http://servername          | Default  | http://servername         |   
| http://portal.company.com  | Intranet | http://portal.company.com |  
| https://portal.company.com | Intranet | http://portal.company.com |  
| http://mportal.company.com | Intranet | http://portal.company.com |  
+----------------------------+----------+---------------------------+ 

You are added portal.company and mportal.comany in same zone which causing this issue. What you have to do On the AAM page from central admin > click on Edit public url Enter the url in the following:

**Default:**  http://servername

**Intranet:** http://portal.company.com 

**Internet:** http://mportal.company.com

After saving this, click on the Add internal URLS, Enter the http**s**://portal.company.com url and select the Intranet zone from drop down and click save.

i think it should be like this

|        internal URL        |   Zone   |        Public URL         |   
+----------------------------+----------+---------------------------+   
| http://servername          | Default  | http://servername         |   
| http://portal.company.com  | Intranet | http://portal.company.com |   
| https://portal.company.com | Intranet | http://portal.company.com |  
| http://mportal.company.com | **Intrenet** | http://portal.company.com |  
+----------------------------+----------+---------------------------+
  • Unfortunately, this aam configuration is not possible. When we tried to add the mportal internal url the config did fall back to only default zone automatically, so we have tried other options and come up with the solution below. Thanks for help ;) – Toumash Feb 26 '18 at 9:05
0

There was a problem with HSTS (HTTP Strict Transport) on domain company.com, and deleting it on chrome didnt work, so we went to portal.company.mobile to workaround that, and when our proxy guy confirmed that its working, we switched to the schema below.

AAM

+-----------------------------------+-----------+---------------------------------+
|            Internal URL             |    Zone   |           Public URL            |
+-----------------------------------+-----------+---------------------------------+
| http://servername                 | Default   | http://servername               |
| https://portal.company.com        | Intranet  | http://portal.company.com       |
| http://portal.company.com         | Intranet  | http://portal.company.com       |
| https://mportal.company.com:8080  | Ekstranet | http://mportal.company.com:8080 |
| http://mportal.company.com:8080   | Ekstranet | http://mportal.company.com:8080 |
+-----------------------------------+-----------+---------------------------------+

IIS

+----------------------+---------+
|         site         | binding |
+----------------------+---------+
| portal.company.com   | *:80    |
| mportal.company.com  | *:8080  |
+----------------------+---------+

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.