0

I am trying to to install search service on SharePoint 2010 farm, and getting following error

Errors were encountered during the configuration of the Search Service Application.

In logs I found following error:

The call to SearchServiceInstance.Provision (server '<servername>') failed. Setting back to previous status 'Disabled'. System.OverflowException: Arithmetic operation resulted in an overflow.     at Microsoft.Office.Server.Search.Administration.UnsafeNativeMethods.NetLocalGroupGetMembers(String groupName)     at Microsoft.Office.Server.Search.Administration.UnsafeNativeMethods.TraceLocalGroups()     at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Provision()     at Microsoft.Office.Server.Search.Administration.SearchAdminUtils.DeployLocalServiceInstance[T](T localSearchServiceInstance) 

I have checked WSS_WPG group it does not have many users, as suggested by some soultions. Any help, clues to where to look for this error

0

Did you try looking into ULS Logs deeper to find the group name? It does not necessarily have to WSS_WPG Group.

From this we could figure out that it errors out while enumerating members of one of the local group. On a closer review of the ULS logs I was able to figure out the problematic group:

Reference : Technet blog about issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.