1

I need to upload a couple of large archives to a SharePoint's document library, but anytime the upload finishes, the uploaded file is 0KB.

Tried the following upload options, which all resulted the same issue:

  1. Explorer View (Client)
  2. Drag and Drop (Client)
  3. Mapped drive (Client)
  4. Mapped drive (Server)

Additional details:

  • SharePoint version: 2013 Foundation
  • File size: 4GB (split into 4 parts, 1GB per each)
  • The maximum allowed upload: 2000MB (set in Web Application General Settings)
  • Available hard drive space: 40GB+
  • Site collection: newly created, not containing any data

Does anyone have any ideas what else I should look into?

0

Since basically the upload system is under classic asp.net application configuration, can you check the web.config lines

let me know if it helps! :) cheers

  • i was referring to code <configuration> <system.web> <httpRuntime maxRequestLength="xxx" /> </system.web> </configuration> code "xxx" is in KB. The default is 4096 (= 4 MB). – Fabrizio Chionni Feb 15 '18 at 13:52
  • 1
    Thanks for your answer, but it worked after some period of time. I just left the file as it is with 0KB, and was monitoring it refreshing the DL it was stored in. After approximately 2 hours it showed the correct file size. – Emil Gurbanov Feb 15 '18 at 13:58
  • 1
    @EmilGurbanov Thanks for sharing that. I had an issue with zip files showing up empty in SharePoint; never thought to wait a while and check again later. You should post this as the answer so others with the same problem. can find it. – freginold Feb 15 '18 at 15:09
0

If anyone is having similar issues, my solution was the following:

Uploaded files, and gave it some time (appx. 2 hours), after which refreshed the explorer view and discovered that file size showed correct value.

I think this is caused by processing the large files during upload, since they are saved in DB instead of File-system.

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.