I’m relatively new to workflows and need some help please with SharePoint 2013?

The requirement is as follows:-

Users will add list items via an InfoPath form. This item will also include the selection of a specific user from a SharePoint group who will be the approver The new list item will trigger a workflow & send an email to the approver I want the approver to review the item & either approve or reject with the ability to add comments.

I also want to remove all fields from the task apart from Approve/Reject, Title (linked to item), creator of the list item & a comments section.
This is the main part I’m stuck on & I’ve tried many ways to get this to work.

I’ll be using the 2013 WF. How, I’ve tried to get this to work is simply hiding the unnecessary columns but the approval seems to base itself on being either complete or on the status (& not the Approve/Reject).

& finally an email sent to the creator with notification of approval/rejection along with the comments.

It’s also worth mentioned that I do not want to use content approval as the solution as I’d like to expand upon the workflow at a later date.

Image of what I've achieved so far.

enter image description here

Many thanks in advance for any help & guidance, John

1 Answer 1


task forms are auto-generated based upon a certain Content Type, to customize the task form you'll need to create and customize a new workflow tasks contents type as i explain in the below steps

1. Create a Custom workflow task content type

Navigate to

Site Settings - under Web Designer Galleries - Site content types - Create

enter image description here

Under parent Content Type, choose List Content Types in Select parent content type from And Workflow Task (SharePoint 2013) in Parent Content Type

enter image description here

2. Add the content Type to your Tasks List

After creating the new workflow task content type you need to add it to your tasks list Navigate to Site Contents - Tasks (Yours tasks list) , is this example I’ll use the default tasks List . Open the List Settings - under the Contents Types - Add from existing site content type Select your custom contents type click add then OK.

enter image description here

3. Modifying the new content type view

Navigate to Site Settings - under Web Designer Galleries - Site content types Click on the new content type (MyCustomTaskContentType)

enter image description here

Select the column you need to hide
enter image description here
Under the Column Settings - Select Hidden (Will not appear in forms) then OK
enter image description here

4. Assign the Content Type to your designer workflow Start a Task Process and Assign a Task actions

In the Start a Task Process or Assign a Task , you should define the Task Content Type in the outcome options to the new content type.

  • Thank you. I've followed your advice but stuck on the final bit whereby I define the Task Content Type in the outcome options to the new content type. Can you elaborate further please?
    – Johno
    Commented Feb 14, 2018 at 9:53
  • Note. I have set my new content type against the 'ContentTypeId' in the 'Start a task process Properties'. A task is created. When I Approve or Reject the workflow shows cancelled with a deleted association & a subsequent instance of the workflow is started showing activity in progress?? Any idea?
    – Johno
    Commented Feb 14, 2018 at 10:11
  • @Johno deleted association problem usually appear when you previously delete a workflow , is that the case with you?
    – A.Saéed
    Commented Feb 14, 2018 at 11:07
  • @A.Sayéed. Yes, I had a couple of previous attempts at building the workflow & decided to delete it along with the workflow task list & start afresh. Do you have any advice to remedy the issue please?
    – Johno
    Commented Feb 14, 2018 at 13:06
  • @Johno from your list go to Settings - Workflow Settings- click on" Remove, Block, or Restore a Workflow" & check for the deleted workflows if they still showing up
    – A.Saéed
    Commented Feb 14, 2018 at 16:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.