0

I am using an out of box SharePoint 2010 - Approval workflow in my SP 2016 site. In some of the cases when we approve the task, the task gets completed and document shows in approved state but the workflow doesn't get marked as completed. This happens only for some of the tasks.

Any ideas.

0

Which state does the workflow display if the status of the workflow is not "Completed"? enter image description here

And you could check if there is error information in the workflow information page.

To troubleshoot the issue, you could re-create the out of box SharePoint 2010 - Approval workflow to check if the same issue occurs.

  • This workflow is single state Workflow. There is no error in workflow. This error I am facing on a particular site only not in any other. – notorious Feb 9 '18 at 8:50
  • If the issue only occurs in some tasks, you could terminate the workflow and re-run the workflow in the list item which has the issue. – Amy_MSFT Feb 9 '18 at 9:02
  • The status is displayed as completed. Yes, I can do that. But I just wanted to find the root cause of the issue, because re running the workflows might not seem a good practice. – notorious Feb 9 '18 at 9:21
  • if the status of the workflow is "completed", then the workflow completes. – Amy_MSFT Feb 9 '18 at 9:52
  • But that's the problem here. I still get that end this workflow link in workflow information page. That I think doesn't come in case of completed workflow. – notorious Feb 9 '18 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.