3

I was hoping to find an answer to my issue in this article but when adding multiple content types I run into a couple of issues. It works fine for .dotx templates, so I tried the same with an Excel and a PowerPoint template, but to no avail, I guess they don't like the "Document" parent type, or I must be missing some other point.

Firefox throws a "'New Document' requires a Microsoft SharePoint Foundation-compatible application and web browser." Why does it work with Word but not with Excel & Powerpoint?

Other browsers (Chrome, IE11, Edge) work to some extent. With PowerPoint custom content type: - clicking New on a Library WebPart opens Powerpoint, attempts to authenticate to the domain and then says it can't connect. - clicking New on the Library page itself creates a new file "POTX File.potx" based on the template in the library, but you have to open it manually.

With Excel custom content type: - clicking New while Excel is already running on your PC creates a new book1.xlsx based on the template. - clicking New when Excel is not running opens Excel but doesn't load the template.

Does somebody have some insight on this? Thanks!

2

I need to collect the following information to further troubleshoot the issue:

Are you working in SharePoint online or SharePoint 2013?

If you are working in SharePoint 2013, have you configured OWA for SharePoint 2013?

Please offer a screenshot about where you are using the 'New Document' button.

Make sure the "Office Document Cache Handler" and "SharePoint OpenDocuments Class" managed ad-on are enabled:

enter image description here

Ensure you have valid entries inside DOCICON.XML

Folder: C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\TEMPLATE\XML

Here are some articles for your reference:

http://susheeldakoju.com/?p=1049

http://www.jeanpaulva.com/index.php/2012/08/15/error-new-document-requires-a-microsoft-sharepoint-foundation-compatible-application-and-web-browser-to-add-a-document-to-this-document-library-click-the-upload-document-button/

  • SharePoint online and Office 2016. None of the mentioned add-ons are present. I have no Web Server Extensions folder on my PC, either. How do I respond and attach a screenshot? Thanks. – Jondalar Feb 16 '18 at 8:41
  • btw the first link refers to Office 2010 and the second throws a 503. – Jondalar Feb 16 '18 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.