1

I have a Workflow that has stopped working. As far as I am aware there have been no changes made to either the Workflow or the SharePoint Farm.

If I select an item from the list the Workflow runs against and select Workflow I get a Correlation ID error. Used Merge-SPLogfile to get the log file and the error message reads :-

Application error when access /layouts/15/Workflow.aspx, Error=A response was returned that did not come from the Workflow Manager. Status Code = 200

Googling the error reveals a lot of issues when installing Workflow Manager but not how to resolve this issue on a mature system.

Any help greatly appreciated as always,

Dan

0

Here are some troubleshooting steps:

  1. Make sure the Workflow Manager farm is running. And make sure the workflow service is connected to SharePoint.

  2. Install Workflow Manager updates. Make sure the Cumulative Updates (CU) for SharePoint Server 2013 and Workflow Manager are installed in a coordinated fashion.

    Update Workflow in SharePoint Server 2013

  3. Disable loopback check.

  4. Created a new scope and register the workflow service using Register-SPWorkflowService.

  5. Add Workflow service account as “WFServiceOperators” into the databases (WFInstanceManagementDB and WFResourceManagementDB)

  • JoannaW , thanks. I'm working my way through your suggestions with the Client. This may take some time but I'll update the thread further when we manage any progress. – Dan Feb 21 '18 at 9:59
  • This ran into further issues and a decision above my head was made to scrap it and rebuild. So I never got to the bottom of this unfortunately. Thanks for your advice Joanna, appreciate it. – Dan Feb 27 '18 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.