0

I had to remove a faulty Search Service Application. When removing the search app I ran into problems and ended up using stsadm.exe -o deleteconfigurationobject -id "GUID" among other commands to remove it from the Service Applications list. Ran psconfig at the end.

Trying to create a new Search Application, without any luck. Tried first from the GUI, and then with powershell.

Looks like there is a problem when creating the webservices in the application pool.

0

You could run the PowerShell command below to remove the search service application.

$spapp = Get-SPServiceApplication -Name "<Search Service Application display name>"

Remove-SPServiceApplication $spapp -RemoveData

And then re-start the “SharePoint Timer Service” and “SharePoint Administration” service in services.msc.

Did you receive some error message when re-creating the new search service application? If you did, could you please share the error message?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.