1

I am a new owner of a SharePoint site, and am trying to set it up so that I receive an email whenever a user requests access. I have gone into Site Settings -> Site Permissions -> Access Request Settings (on the Permission Tab) and put in my email in the dialog window. Even after doing this though I am still not receiving emails when a user requests access.

The only potential issue I can think of is that I am not the original owner of the SharePoint site, and the previous owner had his email set up to receive notifications when a user requested access. We have since gone in and deleted his email and put mine in instead, but the issue persists.

Does anyone know what I can do to make sure that I receive email notifications for when a user requests access? Otherwise I will have multiple requests aging while I am unaware.

Thank you in advance for any help!

  • what is your permission level? how many email address on the Acess requests settings? – Waqas Sarwar MVP Feb 6 '18 at 21:54
  • I have Full Control for the Site Collection, so it's my understanding that I should be able to edit the email address on the Access Request Setting. And now it is just one email address (mine). We had tried to have it be both mine and the previous owner, but we still ran into the same issue of me not receiving any email notifications. – J. Shlabotnik Feb 6 '18 at 22:41
  • is any body getting the emails, when you add both account or if it is just your email address? – Waqas Sarwar MVP Feb 6 '18 at 23:01
  • When both of our emails were listed then the original owner continued to get emails. Now that it is just my email, the original owner no longer receives emails. – J. Shlabotnik Feb 6 '18 at 23:35
  • Add yourself into site collection admin group then try again....site setting> permission check site collection administrator – Waqas Sarwar MVP Feb 7 '18 at 0:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.