0

We implemented ADFS in our UAT environment. I just realized I cannot create subsites on any site collection. I can delete sites, manage permissions, and do everything else, just not create new sites. I am a site collection admin both on the site and in central admin. I also noticed that when I use the non-ADFS farm account, I can create a sub site. When I try as an adfs account, I can enter all the site info but get "Sorry, you don't have access to this page" when I click the create button. Even if I add myself to the user policy of the web app with full control, I still can't do it.

The Object cache accounts are in the web app with proper permissions

I tried stopping and starting the Microsoft SharePoint Foundation Web Application service

I reran Convert-SPWebApplication

I checked that sites are allowed to be created in the policy permissions

I ran psconfig

I found many similar issues on the web, but none were exact and the solutions made no difference.

This ADFS conversion has been aggravating. Just when you think you got it working, something else happens.

1

I had another user, who was also a site collection admin, test adding a site. He was able to do it. It appears there was something corrupt with my user profile. I deleted my account from the user information list and the UPA and now I can add sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.