1

I have several site collections in my web application. I was the primary administrator and also farm admin. I wanted to enable access to the welcome page without login so I checked "enable anonymous access" at authentication providers of the web application.

Sharepoint 2016 Central administration -> Appl management -> Manage web appl -> my web application -> authentication providers in the ribbon, then the active auth provider link in the dialog and check "enable anonymous access".

Now unfortunatelly I lost access to my site collections in this web application. I unchecked/cleared the box of "enable anonymous access" but it did not solve the problem.

enter image description here

When I tried to open the sites in IE I got http 404. It looks like I lost the sharepoint groups - visitors, owners, members. I tried to recreate and associate them at central admin but now I got "You need permission to access this site".

Now I simply want to get back access to my sites, anonymous access is not important.

Any help appreciated.

Thanks!

  • I use Sharepoint 2016 – Ivanhou Feb 5 '18 at 22:35
  • Are your sites, "normal" team sites or publishing sites? – Sergio Feb 5 '18 at 23:40
  • My sites are normal team sites. – Ivanhou Feb 6 '18 at 7:53
1

After unchecking the Enable Anonymous Access, you will get the below error

Sorry, you don't have access to this page

To avoid this issue, Try to do the following:

  • Central Administration > Application Management > Site Collections > Change Site Collection Administrators.

  • Make sure you have the correct Site Collection.

  • Remove then Re-add the same site collection administrators > then click Ok.

enter image description here

  • Go back to browse your site, it should be now working properly.
  • I did exactly what you suggested but no change. Still shows you need permission. I tried also another secondary collection administrator but got the same result. – Ivanhou Feb 6 '18 at 7:53
  • I simulated the same scenario on my side and working properly, are you sure, you have selected the correct web application and site collection! – Mohamed El-Qassas MVP Feb 6 '18 at 18:05
0

Whether you cannot access all the Sites/lists/Pages in the web application? Try to troubleshoot this issue as following:

  1. In CA->Manage web application->click the relevant web application->User Policy, add your account with Full control.

  2. Access Site collection administrators page though URL http://spsite/_layouts/15/mngsiteadmin.aspx, check if your account located in that.

  3. Clear SharePoint configuration cache. Run IIS reset.

  4. Check the ULS log to get more information.

0

Finally I managed to solve this issue. It's a bit weird but I went to Sharepoint 2016 Central administration -> Appl management -> Manage web appl -> my web application -> authentication providers in the ribbon, then the active auth provider link in the dialog and checked again "enable anonymous access". Now me and all users have appropriate access to the site collections, all group hierarchy (visitors, owners, etc) remained unchanged. So currently "enable anonymous access" is checked and every user has the correct access.

Thank You all for the suggestions and help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.