0

I have created a local variable in SharePoint designer 2013, called date_time, and set it to long time format. My workflow checks a field in a column of a list on a change. If it passes the check the time will be written to another column in the list. It works except that the date is always 6:00 pm on 12/31/1899. any ideas?

Kelly

3
  • Is that "another column" in a Date and Time format?
    – Sergio
    Feb 1, 2018 at 1:20
  • I had it in date time format, but it would only allow me to set today's date. I need time as well. so I changed it to string. no matter how I pass the variable data, as long time or as string, it's still 12/31/1899
    – Kelly
    Feb 1, 2018 at 1:27
  • My guess is its parsing the date time as a string to a column expecting a different input type, so it defaults to 0. Maybe write the variable to a 'testdate' column that's just text so we can verify it's collecting the right datetime in the first place.
    – J. Doe
    Feb 1, 2018 at 9:19

2 Answers 2

0

Did you set the default value of the workflow variable in the workflow?

And did you set the default value of the column in the list?

To troubleshoot the issue, you could check things below:

  1. Add “Log to history list” action and check the value of the workflow variable in your workflow.

  2. Create a new list and create a new workflow to check if the same issue will occur.

More reference:

Debugging SharePoint Workflows.

http://www.dotnetcurry.com/sharepoint/1045/debugging-sharepoint-workflows

0

I got it to do what I needed by setting the column as "date and time" data type and set it equal to "Workflow Context:Date and Time Started'. Now I have to figure out how to lock down all the columns except the one they can edit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.