0

A few of my clients are having a very specific issue with Word 2016 and how it integrates with our SharePoint 2013 farm.

As the story goes, our user wants to compare a legal document with one of its previous versions; however, trying to do so does nothing. This is literally nothing -- no dialog box or error message is shown, and Word continues working without interruption. I've read elsewhere that the version window sometimes opens without any versions displayed, but this is different in that no dialog box ever displays at all.

We can replicate it like this:

  1. User opens a document with multiple versions from SharePoint in Word.
  2. User checks out the document
  3. User chooses "Specific Version..." under "Compare" in the Review tab of the Word 2016 ribbon

We have performed repairs on Office (which did not solve the issue). All of the affected users have Contribute permissions to the library and can manually download the older versions to compare them manually.

Any ideas on why this is happening would be greatly appreciated.

  • If you find a solution, write it as an answer, thanks :) – Sergio Feb 1 '18 at 15:59
1

Some ideas:

  1. Try 32/64 bits Word version.
  2. Read this. Anything (firewall, VPN, ...) maybe blocking the connection from Word to SP (not from SP to Word of course)?
  3. Reinstall Office 2016 in one PC with troubles to test, if it doesn't work, try to install 2013 and see what happens.
  • Thank you for the ideas, but unfortunately, these weren't the ultimate cause; however, they were very helpful in my troubleshooting. Thanks again! – Jeff Freeman Feb 8 '18 at 16:35
1

The answer turned out to be a corrupted group policy on the client's computer. I am not sure which policy it is, as we ended up rebuilding it from scratch, but something in there messed things up.


Here's how I performed troubleshooting on the issue (in case it helps anyone else):

  1. Attempted to replicate the issue locally (without success).
  2. Tried to replicate the issue from the client site (without success).
  3. Replicated the issue on a particular user's computer
  4. Had that user log into a workstation she had never used before
  5. Attempted to replicate the issue on the other computer (without success)

Based on this, we ruled out SharePoint and Office as the cause of the issue. Since she did not have the issue on a new profile on a different computer, we concluded that her group policies were either corrupted or inconsistent with respect to more recent organizational group policies.

I wish I could have done more troubleshooting to determine exactly which group policy was at fault, but, as we all know, the pragmatic solution is often the most efficient one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.