0

I have a custom list. If a new item is created, I have to send the item's fields in email. I have 2 issue:

  1. The date format is changed in the email. Even if I use "Date only" format for the list, in the email the time is also appear after the date as "12:00:00 AM" what is not correct.
  2. At the person picker I use "Name with presence" and it is correct in the list, but if I try to send it in the mail, the person's ID appear instead of his name.

Where should I configurate the item's formats for the email? I am using SP 2013 for the list and SP 2010 workflow for the email.

1 Answer 1

2

Make sure in the workflow, date field lookup is having return field as "ShortDate" and the person field lookup is having return field as "Display Name" as shown in below screenshot: enter image description here

enter image description here

3
  • May I ask u where can I check that? Both the date and the name is in the correct format in the list. The problem only occurs if I try to send them by a workflow email.
    – Nefri
    Commented Jan 31, 2018 at 10:17
  • Updated my answer with screenshots for better understanding
    – Sagar
    Commented Jan 31, 2018 at 10:21
  • Ahh I see, looks like I overlooked this option. Thanks you very much!
    – Nefri
    Commented Jan 31, 2018 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.