2

I added a page viewer web part in SharePoint page , add the page link ,save and close, no errors, it shows a blank page !!

PS: The page url browsed in the browser normally, I also enabled the iframe in the site settings,

Any thoughts!

  • 1
    Is that happening you with all browsers? URL is same domain as SP or different? Is a HTTPS URL inside a HTTP SP? – Sergio Jan 28 '18 at 16:40
  • Is the URL pointing to a page you created in a web site, or a public site. Many public sites include JavaScript "frame buster" routines that detect IFrames and then redirect, or display an alternate output. What do you see when you right-click inside of the Page Viewer web part and click click View Source? – Mike Smith - MCT - MVP Jan 28 '18 at 18:27
  • Use F12 developer tools to see if there are any errors. Delete other web parts on the page, just leave page viewer web part on the page. Check if it is caused by the conflicts. – JoannaW_MSFT Jan 29 '18 at 9:28
3

This issue usually occurs in case you have edited your page and added the Page Viewer Web Part using Google Chrome!

In Google Chrome, the blank page inside the Page Viewer Web Part means

This content cannot be displayed in a frame!

To make sure that, try to open the same page in Internet Explorer and you will get

enter image description here

So How to solve this issue?

  • Go to Site Collection Settings > Site Collection Administration > HTML Field Security
  • Check Permit contributors to insert iframes from any external domain into pages on this site.

enter image description here

  • Go back to your page and check if the Page URL has been rendered inside the Page Viewer web part or not!

In case, the issue still persists that means the publisher of this content does not allow it to be displayed in a frame.

  • OP stated in question that they enabled iframe in site settings – J. Doe Jan 29 '18 at 8:40
  • 1
    Please, Read the answer carefully and you will know I replied to this point! he talks about the blank page! so I provide detail answer! – Mohamed El-Qassas MVP Jan 29 '18 at 8:44
0

Instead of using a Page Viewer web part just use an iframe in the 'embed code' web part:

<iframe src="https://www.sitename.com/page" width="200" height="200"></iframe>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.