0

I have a simple problem, but I cannot find any solution. When I remove the first row of my InfoPath layout table, it affects the alignment of every other cell in the layout table.

Before (image here)

After (image here)

The rest of the form also displays the same offset (shown by the purple arrow) throughout the entire form.

Is there a way to remove a row in my InfoPath form without it affecting the rest of the form?

  • This is not a solution, it's just a workaround. I remember that when I started using InfoPath 2013 a couple of years ago, tables in my opinion had a strange behaviour and sometimes a pain in the ass. Over time, I opted for: "one row = one table", so, when I put them together, it seemed to be a single table, and those weird problems (like yours) didn't happen. You may try that. – Sergio Jan 26 '18 at 18:30
  • @Sergio unfortunately this form is already deployed and used daily. Recreating the form from the ground up so that one row = one table is not possible. Thank you for the insight though. On other forms in production, I have used the same technique to avoid this problem. – panic Jan 26 '18 at 19:05
0

Is the “Initial Invoice Information” a whole one? I didn’t reproduce this issue in my InfoPath form.

Could you merge the three cells in the first row then delete it? It may resolve your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.