2

I want to allow members to edit/create/delete/update list items, but when I allow permissions "edit", the edit page link is accessible to them:

enter image description here

I've tried solutions, such as:

  1. Break inheritance and set unique permissions for the webpage, but doesn't work either: User Permissions: Shouldn't be able to edit pages, but add/update/delete documents
  2. Creating my own custom permission levels:Stop users from editing and deleting data on list. However I realize that using this option has some issues:

enter image description here

Firstly, the "edit items" allows users to edit list items & customize webpart pages. But I want to edit list items only.

Secondly, I tried clicking the "Approve items" option, but when this happens, the "edit items" option is selected at the same time. I think they are linked together.

Does anyone have any other solutions? All I want is for sharepoint members to not have access to edit the page.

  • 1
    The edit link in the screenshot is for the List Item editing not for the page. – Nadeem Yousuf Jan 25 '18 at 6:28
  • @NadeemYousuf changed the screenshot sorry for mistake – Chris Jan 25 '18 at 6:31
0

This post on MS website explains it pretty well I think.

The groups you are interested in are 'Contribute', 'Edit' and 'Design'. The last one is the 'most powerful' in terms of editing pages. A user can be in any combinations of these groups and the permissions this grants them are cumulative - ensure you check this or it will be confusing. Read through the individual permissions a user has by being in Contribute. Then compare that to Edit, then compare to Design. n.b. Contribute/Edit/Design are standard OOTB user groups. It appears 'Design' enables users to edit pages.

I understand you want users to be able to create/modify List items. In that case they need to be in the Contribute group. Read this post on the SP Maven for extra help. The reading is worthwhile.

Then test security with a friendly user who is in the Contribute group - can they edit the page?

Additional Reading

Best practises

0

Permissions to the list itself would be controlled by the site or list security, via security groups and permission levels. To read more about how to set security properly for the site. However, even if you set unique security for a SharePoint list, it applies to the whole list or in other words – all items.
To set unique permissions behavior for the items themselves, you would need to configure the feature called Item Level Permissions. It is actually quite easy and straightforward.

To enable Item Level Permissions, go to List Settings > Advanced Settings. Scroll a bit down and you will see Item Level Permissions section. Inside the section, you will see two categories - Read access and - Create and Edit access

Hope this explanation helps.

  • I think my main concern is to disable the "edit page" link for members. – Chris Jan 25 '18 at 7:47
  • Yes, you just have to reverse engineer the method above. Read this for full detailes. – JohnKelheim Jan 25 '18 at 7:52
  • I tried choosing different options in item level permissions but it doesn't work. Sorry I don't really understand how to reverse engineer your solution. Also, I think the "edit page" feature itself affects the look of the webpage - not the list/list item itself. – Chris Jan 25 '18 at 8:06
0

Several things...

The Edit Permission Level, added to SharePoint starting with SharePoint 2013, grants the "Manage Lists" permission. This will let users edit the pages in the list/library "Forms" hidden folder. Either change the user's or group's permissions from "Edit" to "Contribute", or edit the "Edit" Permission Level in site collection's top level site to remove "Manage Lists" from the list of permissions.

Pages like the home page are ASPX files stored in a SharePoint library, typically the Pages or Site Pages libraries. Starting with SharePoint 2013 Microsoft gave site users the same permissions to the Site Pages library as they have for the rest of the site. I.e. If they can delete a document, they can also delete your home page! Assuming your page is stored in Site Pages, go to Site Contents, Site Pages, click the LIBRARY tab, click Library Settings and then click "Permissions for this document library". Click "Stop inheriting permissions", and then change everyone's permissions to Read, except for the Site Owners who should still have Full Control.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.