1

Using SP2010, I have a list containing a column with rich text (i.e. contains html). I would like to display this column using a content query web part - but when I do, it displays the actual html, rather than the formatted text. Is there a way around this?

0

2 Answers 2

3

You will probably need to edit the xsl to add a disable-output-escaping attribute.

3
  • I've attempted to make this change to the "ItemStyle.xsl" in the "Style Library" - however, I'm not seeing the changes picked up in the CQWP. Is this not the correct file to modify?
    – Jeremy
    Apr 16, 2010 at 12:54
  • I haven't done this is SP 2010 yet, but I assume its the same as 2007, and yes that should be the right file. Perhaps edit your question to add the change you made and we can check it out.
    – Paul Lucas
    Apr 16, 2010 at 14:43
  • Thanks for the feedback. I figured out that I was adding the disable-output-escaping attribute to the wrong xsl template. I was using the one labeled "Title and Description" - this corresponds to the "NoImage" template in ItemStyle.xsl
    – Jeremy
    Jul 23, 2010 at 22:22
0

Click on the cell, click on the arrow at right top corner of that cell and choose the appropriate format.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.