0

I am trying to start a 2010 workflow (which involves sending an email) from within an 'app step' (i.e. elevated permissions) of a 2013 workflow. However, I am an 'access denied - you do not have permission to access this resource' message.

The workflow runs fine if that particular step which requires starting the 2010 workflow is not invoked. Therefore I concluded, that the app step is not able to start the 2010 workflow. Does anyone here has any thoughts on how can I get around this?

Many thanks

  • You ever find a solution for this? Same problem here – M.P. Mar 13 '19 at 12:33
1

It's by design,

The Start a List Workflow action only run the SharePoint 2010 workflow,

enter image description here

Unfortunately, the SharePoint 2010 workflow is not supported in App step in SharePoint Workflow 2013.


Alternatives

  • Using a REST call to start a workflow,

  • Instead of running the SharePoint 2010 workflow, try to create a remote Event Receiver on a specific event like ItemAdded or ItemUpdated to simulate the same workflow behavior!

| improve this answer | |
  • Thanks. Can you suggest any workaround? – KMLN Jan 20 '18 at 19:16
  • Kindly, check the updated answer! – Mohamed El-Qassas MVP Jan 20 '18 at 21:55
  • The article you quoted talks about starting a 2013 workflow. Can this same method be used for starting a 2010 workflow? – KMLN Jan 20 '18 at 23:33
  • No bro, it's only for SP 2013 WF – Mohamed El-Qassas MVP Jan 21 '18 at 7:47
0

It's not clear from you desciption if you have activated the App step feature on the site. If you have done that have you also granted full permission to the workflow "app" by entering the xml in appinv.aspx?

If not that most properly is the reason as the app hasn't been granted any permission to actually start the workflow.

Grab the id of the workflow under "Site app permissions" Visit /_layouts/15/appinv.aspx Enter the following xml (no placeholders just insert the actual code):

 <AppPermissionRequests AllowAppOnlyPolicy="true">
 <AppPermissionRequest Scope="http://sharepoint/content/sitecollection/web" Right="FullControl" />
</AppPermissionRequests>

The full guide to do it is here: https://docs.microsoft.com/en-us/sharepoint/dev/general-development/create-a-workflow-with-elevated-permissions-by-using-the-sharepoint-workflo

| improve this answer | |
  • I had already activated the App step feature by giving full permissions before I posted this question. As I said, the workflow works fine if the step that involves calling the 2010 workflow is not executed. – KMLN Jan 20 '18 at 17:12
  • I figured out the source of the problem (no solution yet though). It seems that an action to start a 2010 workflow from within an App step is invalid. – KMLN Jan 20 '18 at 17:56
  • what's the meaning of "calling the 2010 workflow is not executed"? Could you tell us how you set steps in app steps and steps in 2010 workflow? – Max576_MSFT Jan 21 '18 at 12:41
  • There absolutely no problem in starting a 2010 workflow from within a 2013 app step. I have several usecases where I'm doing exactly that. But it does require the workflow to have the correct permissions. – Morten K Jan 21 '18 at 18:09
  • @MortenK SPD is not giving me an option to place an action to start a 2010 workflow within an app step. I can do it outside the app step. When I place the action outside the app step and move it up inside the app step, I get an error when saving/publishing the workflow. – KMLN Jan 24 '18 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.