1

I have a SharePoint 2016 development VM where the 'App Installation Service' Timer Job stopped running a couple days ago. It is enabled and scheduled to run every 5 minutes. Clicking 'Run Now' does nothing. The last run was successful. I cannot find anything of value in the logs. The Timer service and SharePoint Administration service are running. The App Management Service, Secure Store Service, Security Token Service, and State Service is running.

  • I've tried disabling the timer job and re-enabling it.
  • I modified the job schedule.
  • I cleared the Config cache
  • I restored the default jobs via $farm = Get-SPFarm; $farm.TimerService.EnsureDefaultJobs()

Has anyone seen this before with a timer job?

  • 2
    as this is development machine, can you try to run pasconfig wizard on the server? – Waqas Sarwar MVP Jan 17 '18 at 20:51
  • 1
    That did it, if you answer the question, I'll award you the points. – James Grizzle Jan 17 '18 at 21:22
  • Great, that trick helped in past. i added another good deed in my account. – Waqas Sarwar MVP Jan 17 '18 at 21:25
4

As this is your Development machine, i would try to re run the Config wizard, we had the same issue in past and re run fixed it.

You can run via gui or command line:

PSConfig.exe -cmd upgrade -inplace b2b -force

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.