0

I am using the following function for a PowerApps survey which is supposed to create list items in SharePoint:

Collect('Test List PowerApps';{Title:Radio1.Selected.Value;Column:Slider1.Value‌​;Tekst:TextInput1.Te‌​xt})

It does create the item, but each column is empty!

I later tried again by making an app through SharePoint. This one uses text alone:

Collect('Test List PowerApps';{Title:DataCardValue1.Text;Column:DataCardValue2.Text;Tekst:DataCardValue3.Text})

In this case, only the "Title" column gets any text. That is regardless of where I place it; So, if I switch Column and Title in function above, only the Title column gets filled with text. The different columns have the exact same settings.

Why am I experiencing this? Is there any workaround I could use?

0

Try using commas instead of semicolons between each item when you are creating your row.

1
  • Well, it's too late now since I don't work there anymore. However, I do remember that while the official documentation does use commas, nothing worked unless I used semicolons (also, the in-app examples all used semicolons). – Avatrin Jan 5 '19 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.