1

I have recently taken over a historical SharePoint site and need to add an additional item to a customised search results page, but the value I added is not showing. I have done the following:

  1. I added a new ‘regular’ column to a list that already contains values that are being crawled and added to the search results. The column I added to the list is not a Site column.

  2. I added a record to populate this new column within the list, and then performed a full crawl.

  3. The added column appeared within the Crawled property results, but as this was not a site column, it did not automatically generate a Managed property.

  4. I made a new managed property and connected the newly found crawled property to this.

  5. I downloaded a copy of the current (customised) html search template html file and updated this to include the newly added managed property, also adding a JavaScript variable and html output for this property.

  6. I uploaded the updated html file and re-ran the search, but the newly added property is not showing.

The existing managed properties follow the standard naming convention, but I do not know if these were site columns that were automatically generated or not. The modified list shows no ‘Catalogue settings’ option under the ‘General Settings’ header of the ‘List Settings’. I expected this to be there. There does not appear to be a catalogue for this list, and I am not sure why the other values are showing but my newly added one is not.

I have not done anything other than the steps mentioned above, so please do not assume anything else has been setup, and this looks different from what I have seen before (no catalogue). Am I missing something?

  • Does the managed property show up when using the SP query tool? If that is the case then the display template is the problem, but did you publish the template after uploading it? – Kasper Bo Larsen Jan 15 '18 at 16:44
  • The templates are assigned to the web part and this is checked in and published. I tested the display template by using another managed property that I knew does work, and this showed up in the search as expected. So, it doesn’t appear to be an issue with the template. This doesn't look like it is found as a managed property in SharePoint Search Query. – Garry_G Jan 16 '18 at 14:55
  • I also tried this with a Site Column, which automatically made the crawled and managed properties. But using the auto-generated property with the template also failed to give any results. – Garry_G Jan 19 '18 at 9:16
1

Ensure below:

  1. Managed properties are properly mapped to required crawled properties
  2. Do a full crawl
  3. Ensure that the display template (if edited by adding the new managed property) is uploaded and published
  4. Ensure that the "Update" link in the notification bar is clicked in Result types screen (better to check both at spweb and spsite levels)
  5. Clear browser cache

Perform a search now and see if the new MP is coming up. If still they are not showing up, use the Search SearchQueryToolv2.6 to query and find if the Search API is throwing them up. If all seems fine then do below

Final nail in the coffin would be restarting the SP Timer and SP Administration services. (This step made my changes reflect. Though for others, it worked at step 5)

  • I found a result as expected using the 'SharePoint Search Query Tool v2.7' and used a refiner of 'managedproperties(filter=600/0/*)' to get the managed property name (MarketplaceItemStatusOWSCHCS). So the crawl appears to be populating the managed property but nothing is showing through the template. This is working as expected through a normal SharePoint search, and the template works fine if another managed property is put through the JavaScript variable. I tried all of the above but it still isn't working. – Garry_G Jan 19 '18 at 14:59
  • did you clear the SharePoint Configuration cache? – Anand Jan 22 '18 at 19:45
0

Try visiting the Result Type Rule page for the Search Site. Often with new managed properties there will be a yellow banner indicating that the properties need to be "Updated". Click the link and try your query testing again.

  • Hell Matthew, I had looked there already, nothing was showing. More than one person has tried to add a managed property now and no new properties are showing when added to this template. – Garry_G Jan 19 '18 at 9:11
  • I would use the SharePoint Search Query Tool to verify that your property is set up and delivering values. Then troubleshoot the Display Template. – Matthew McDermott Jan 19 '18 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.