Apologies if this is the wrong stack to post this in.

This issue is WebDAV related, involving both SharePoint 2013, and Windows 7. I will limit this topic to 3 Windows 7 Machines, and 2 SharePoint 2013 farms (although it affects a lot more machines).

  1. W7-1 (Windows 7 Client #1)
  2. W7-2 (Windows 7 Client #2)
  3. W7-3 (Windows 7 Client #3)
  4. SP-1 (SharePoint 2013 Farm #1)
  5. SP-2 (SharePoint 2013 Farm #2)

I have noticed inconsistent behaviour involving WebDAV, which can be summed up like this:

  1. W7-1 works on SP-1 but not SP-2
  2. W7-2 works on SP-2 but not SP-1
  3. W7-3 works on both SP-1 and SP-2

Further information about this set up:

  1. WebClient service is running on all machines
  2. SharePoint instances are root site collections (No managed paths with roots missing)
  3. Same user account used for all test, so not a permissions issue
  4. There is no firewall or proxy between client machines and SharePoint farms
  5. SharePoint sites are added to "trusted sites" in Internet Explorer
  6. Behaviour is the same for "open in explorer" view, or using a WebDAV UNC path in Windows Explorer
  7. I don't think that this is a hotfixes issue, due to all clients working on at least one sharepoint box.
  8. All Windows 7 clients are 32 bit

I can't figure out why the client machines can't connect to all SharePoint boxes with WebDAV!

Can anyone help?

Edit :

Here are the errors from one of the machines:

WebDAV errors

  • What error do you receive on the affected clients?
    – MHeld
    Jan 15, 2018 at 10:50
  • It's usually an error about adding the domain to trusted sites. It is already in trusted sites if initiated in the browser. I'll need to check what the error is when attempted via UNC path. Jan 15, 2018 at 14:10
  • 2
    Could you please specifiy the exact error? "an error" is not an helpful message for troubleshooting. Thank you!
    – MHeld
    Jan 15, 2018 at 14:33
  • I was also kinda hoping to see an actual error or detailed problem description. is the open with explorer grayed out? is it clickable but nothing happens? is it clickable but throws an error? which error? also suggest to setup a page and use CoreInvoke to programatically open explorer and look for potential error messages Jan 15, 2018 at 15:24
  • Added screenshot of errors, 4 different attempts to gain access via webDAV. Apologies for that omission! :) Jan 15, 2018 at 16:47

2 Answers 2


You have enabled SSL. You may have enabled Basic Authentication on your SharePoint WebApplications. There is lots of trouble with Windows 7 in that scenario.

You might also experiment with the AuthForwardServerList. You will need this in addition to IE's Trusted Sites zone!

  • We have claims authentication throughout the farms. Thanks for the AuthForwardServerList link, I'll give it a look. Jan 16, 2018 at 9:28
  • 1
    Please do not mix up claims and basic. They can be deployed side-by-side. See here how to configure and check if basic is enabled: technet.microsoft.com/en-us/library/gg576953.aspx
    – MHeld
    Jan 16, 2018 at 9:39
  • Oh, I see what you mean. So, Checking IIS, the only Authentication mechanisms that are enabled are : Anonymous (which we don't use), ASP.NET Impersonation, Forms (302 Login Redirect), and Windows Auth (401 Challenge). Basic is disabled, as is Digest. Jan 16, 2018 at 10:00
  • 1
    OMG.. I should fully read MS-articles before linking them.. Reference for future readers: Please do NOT configure this setting directly in IIS. This must be done in CentralAdmin -> Manage Web Applications -> Authentication Providers.
    – MHeld
    Jan 16, 2018 at 10:11
  • 1
    Or PowerShell ;) Jan 16, 2018 at 10:24

I had similar issue in the past with webDAV (back in the days of XP and SP2007) took me couple of months before I managed to figure it out. In my case even though that the XP client machines were on the same build the webDAV dll version was different (Desktop engineers could tell me how that is possible). Ensuring same version of the dll resolved the issue. Maybe it is similar case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.