0

I have a custom list with a lot of items. The search sometime does not work.

For example if the title is

ccc

even if I write

ccc

directly in the search box it doesn't find the item even though I can see it on the list before I do the search . Even if I try like

c*

or

*c

While it can still find if I search for a single word in a more complex sentence.

For example like: "How are u?" if I search for "you" it finds this row. So how the search works and how can I find the simple single word matches?

I add some examples for the better understanding:

Here is the list: enter image description here

Here are the search results:

enter image description here enter image description here

Even if I click on the "Include" it not find anything.

12
  • 1
    in the search box you searching "ccc" or ccc
    – Ali Jafer
    Jan 11, 2018 at 11:57
  • Simply ccc. So without the "".
    – Nefri
    Jan 11, 2018 at 12:23
  • try searching with ""
    – Ali Jafer
    Jan 11, 2018 at 12:28
  • Sadly the same result.
    – Nefri
    Jan 11, 2018 at 12:48
  • what search are you using? the one with the list and not the site search box top right?
    – Ali Jafer
    Jan 11, 2018 at 12:52

1 Answer 1

1

You will have to wait for the crawl to occur before you can search. I did a test with a new column and data (row) filed in the field and as expected nothing. Waited until the search crawl occurred and is now visible. Im on sharepoint online so the search indexing is quick. If onpremise would depend on your setup. could be a whole day or half day or every hour/mins.

2
  • Yeah that was it! I had to w8 3 hours and now works. It was rly confusing, thanks u very much for the advice!
    – Nefri
    Jan 11, 2018 at 15:33
  • happy to help! :)
    – Ali Jafer
    Jan 12, 2018 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.